1С HTML Шаблоны / HTML Templates

Программирование - Инструментарий

Быстрая и удобная обработка для работы с шаблонами HTML. Позволяет легко и быстро формировать код HTML.

Использование

Шаблон может быть, например, такой:

Шаблон = "<h3>{%=о.Заголовок%}</h3>
         |<p>Обработка для работы с шаблонами HTML
         |<a href=""{%=о.Ссылка.Адрес%}"">{%=о.Ссылка.Заголовок%}</a>.</p>
         |<h4>Особенности</h4>
         |<ul>
         |{% Для Каждого Особенность Из о.Особенности Цикл %}
         |    <li>{%=Особенность%}</li>
         |{% КонецЦикла; %}
         |</ul>";

"о" (строчная буква) является ссылкой на параметр данных функции шаблона (см. раздел API о том, как изменить этот идентификатор).

Далее добавляем этот шаблон в кеш обработки:

ШБЛ = Обработки.ШаблонHTML.Создать();

ШБЛ.ДобавитьШаблон("Пример", Шаблон);

В коде приложения создайте структуру для использования в качестве данных для шаблона:

ДанныеШаблона = Новый Структура;
ДанныеШаблона.Вставить("Заголовок", "1С HTML Шаблоны / HTML Templates");

ДанныеСсылки = Новый Структура;
ДанныеСсылки.Вставить("Адрес", "infostart.ru/public/702438/");
ДанныеСсылки.Вставить("Заголовок", "страница обработки");

ДанныеШаблона.Вставить("Ссылка", ДанныеСсылки);

Особенности = Новый Массив;
Особенности.Добавить("Легкая и быстрая");
Особенности.Добавить("Мощная");
Особенности.Добавить("Универсальная");

ДанныеШаблона.Вставить("Особенности", Особенности);

Для получения результата, необходимо вызвать функцию ПрименитьШаблон() первый параметр которой - шаблон, а второй структура данных которые необходимо подставить в шаблон:

Результат = ШБЛ.ПрименитьШаблон("Пример", ДанныеШаблона);

В результат выполнения функции, мы получим следующий результат:

<h3>1С HTML Шаблоны / HTML Templates</h3>
<p>Обработка для работы с шаблонами HTML
<a href="infostart.ru/public/702438/">страница обработки</a>.</p>
<h4>Особенности</h4>
<ul>
  <li>Легкая и быстрая</li>
  <li>Мощная</li>
  <li>Универсальная</li>
</ul>

 

API

 

Функция _tmpl(Строка)

Функция преобразует переданный в параметре Строка текст шаблона в код 1С.

 

Кодирование вывода

Для замены специальных символов HTML в выводе шаблона используется функция _encode(Строка).

Результат = ШБЛ._encode("<>&""'\x00"); // Результат будет "&lt;&gt;&amp;&quot;&#39;"

_encode(Строка) использует регулярное выражение encReg и карту кодирования encMap для соответствия и замены специальных символов, которые могут быть изменены для изменения поведения выходной кодировки.
Строки, соответствующие регулярному выражению, но не найденные на карте кодирования, удаляются из вывода. Это позволяет, например, автоматически обрезать входные значения (удаление пробелов из начала и конца строки):

ШБЛ.encReg = "(^\s+)|(\s+$)|[<>&""'\x00]";
Результат = ШБЛ._encode("    Привет!    "); // Результат будет "Привет!" (без пробелов)

 

Аргумент функции шаблона

Сгенерированные функции шаблона содержат один аргумент, который является структурой данных. Этот аргумент доступен внутри текста шаблонов как параметр о (строчная буква).

Имя аргумента может быть изменено путем переопределения arg:

ШБЛ.arg = "p";

ШБЛ.ДобавитьШаблон("Пример", "<h3>{%=p.Заголовок%}</h3>");

// Результат будет <h3>1С HTML Шаблоны</h3>
Результат = ШБЛ.ПрименитьШаблон("Пример", Новый Структура("Заголовок", "1С HTML Шаблоны"));

 

Синтаксис шаблонов

Печатать переменную с специальными символами HTML:

<h3>{%=o.Заголовок%}</h3>

Печать переменной без экранирования:

<h3>{%#o.Идентификатор%}</h3>

Печать вывода вызовов функций:

<a href="#">{%=ВРег(o.ИмяСсылки)%}"></a>

Используйте точечную нотацию для печати вложенных свойств:

<strong>{%=o.Автор.Имя%}</strong>

Использование условий Если Иначе:

{% Если ЗначениеЗаполнено(o.Автор.Ссылка) Тогда %}
    <a href="{%=o.Автор.Ссылка%}">{%=o.Автор.Имя%}</a>
{% Иначе %}
    <em>Нет ссылки на автора.</em>
{% КонецЕсли; %}

Использование циклов:

<ul>
{% Для Каждого Элемент Из o.Товары Цикл %}
    <li>{%=Элемент%}</li>
{% КонецЦикла; %}
</ul>

Обработка тестировалась на платформах 8.0, 8.1, 8.2, 8.3. Подходит для любой конфигурации.

Бесплатная техническая поддержка 1 месяц

Сравнение версий

1.0 (19.12.2017)

  • Первый релиз.

Гарантия возврата денег

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.



Новый вопрос

E-mail*
Тема (вопрос)*

См. также